Installation problem. Thanks!

Current eOn code and boinc distributed computing

Moderator: moderators

Post Reply
tanlx
Posts: 3
Joined: Thu Sep 04, 2014 7:44 pm

Installation problem. Thanks!

Post by tanlx » Thu Sep 04, 2014 8:01 pm

I want to use EON, but I met problem problem to install EON in my our Linux cluster first time according to steps in website :http://theory.cm.utexas.edu/eon/installation.html.
Question 1: I use the linux cluster form LSU and do not have root permission to install Eon system-wide by command "$ sudo python setup.py install". Is this step necessary for EON using for everybody?
question 2: I can not do the step shown in the question 1. But I continue to do the next to do client installation. But when I " $ cd client" and run "$ make", there is error as following:
[tanlx@philip1 client]$ make
make -C potentials/EMT/ CC="gcc" CXX="g++" LD="ld" AR="ar cru" RANLIB="ranlib" CXXFLAGS="-Wall -Wno-unused-local-typedefs -Wno-unused-function -Wfatal-errors -O2 -DLINUX -DNDEBUG"
make[1]: Entering directory `/home/tanlx/eon/client/potentials/EMT'
g++ -Wall -Wno-unused-local-typedefs -Wno-unused-function -Wfatal-errors -O2 -DLINUX -DNDEBUG -c -o EffectiveMediumTheory.o EffectiveMediumTheory.cpp
cc1plus: error: unrecognized command line option "-Wno-unused-local-typedefs"
make[1]: *** [EffectiveMediumTheory.o] Error 1
make[1]: Leaving directory `/home/tanlx/eon/client/potentials/EMT'
make: *** [potentials/EMT/] Error 2
Could you tell me what the error mean? How to solve them?
Thanks.

chill
Posts: 96
Joined: Tue Jul 28, 2009 9:04 pm

Re: Installation problem. Thanks!

Post by chill » Thu Sep 04, 2014 8:28 pm

It looks like you have an old version of GCC that doesn't recognize the "-Wno-unused-local-typedefs" flag. This flag just tells GCC not to give a certain warning during compile. You can remove these type of flags by editing "eon/client/Makefile" and changing the line from:
CXXFLAGS += -Wall -Wno-unused-local-typedefs -Wno-unused-function -Wfatal-errors $(OPT)
to:
CXXFLAGS += $(OPT)

Let me know if that fixes the issue. If you have some more problems that are related to the compiler please also provide the output of the command "gcc --version".

tanlx
Posts: 3
Joined: Thu Sep 04, 2014 7:44 pm

Re: Installation problem. Thanks!

Post by tanlx » Fri Sep 05, 2014 2:57 pm

Hi Chill,
Thanks very much. The compile is get through. But there is no client excutable Client command generated.
Do you know why?
Another question, Does the step in my last question 1 to copy file to python directory be skipped?

Liuxi Tan

chill
Posts: 96
Joined: Tue Jul 28, 2009 9:04 pm

Re: Installation problem. Thanks!

Post by chill » Fri Sep 05, 2014 3:53 pm

Hi Liuxi,

The name of the exeuctable is "eonclient". The documentation was out of date so I have updated it.

I don't understand your other question. Could you rephrase it?

Thanks,
Sam

tanlx
Posts: 3
Joined: Thu Sep 04, 2014 7:44 pm

Re: Installation problem. Thanks!

Post by tanlx » Fri Sep 05, 2014 4:00 pm

Hi chill,
Thanks. I found the executable command "eonclient".
My question: When I execute the command "$ sudo python setup.py install", I found I do not have permission to execute this. Can I skip this step? If I can skip this , what else need to do?

Liuxi Tan

chill
Posts: 96
Joined: Tue Jul 28, 2009 9:04 pm

Re: Installation problem. Thanks!

Post by chill » Fri Sep 05, 2014 4:04 pm

I see what you mean. All that is need is to have the eon python module listed in the PYTHONPATH environment variable. If you have extracted eon to your home directory then the following line in your bash .profile file will install eon:

export PYTHONPATH=$HOME/eon:$PYTHONPATH

Or you can install the eon python module for all users on the system by executing the setup.py as root.

Post Reply