Bader script is not responding while calculating Bader charge

Bader charge density analysis

Moderator: moderators

Post Reply
TimmonsWang
Posts: 3
Joined: Fri Nov 22, 2019 5:12 pm

Bader script is not responding while calculating Bader charge

Post by TimmonsWang »

Dear all,

I have used Bader script in VASP 5.4 for several times, it was working properly before, but this time the script is not responding and stopped at this stage (after CHGCAR is calculated):

$ ./chgsum.pl AECCAR0 AECCAR2 ; ./bader CHGCAR -ref CHGCAR_sum;

Atoms in file1: 59, Atoms in file2: 59
Points in file1: 2985984, Points in file2: 2985984

GRID BASED BADER ANALYSIS (Version 1.03 11/13/17)

OPEN ... CHGCAR
VASP5-STYLE INPUT FILE
DENSITY-GRID: 96 x 96 x 324
CLOSE ... CHGCAR
RUN TIME: 1.61 SECONDS

OPEN ... CHGCAR_sum
VASP5-STYLE INPUT FILE
DENSITY-GRID: 96 x 96 x 324
CLOSE ... CHGCAR_sum
RUN TIME: 1.05 SECONDS

CALCULATING BADER CHARGE DISTRIBUTION
0 10 25 50 75 100
PERCENT DONE: **

The percent done is not moving forward even after 12 hours of waiting.
The POSCAR1 INCAR POTCAR KPOINTS used in this calculation were attached.
I was wondering if the 5x5x3 KPOINTS is too high to calculate, so I tried 1x1x1 while other conditions remain unchanged, but the script was still stopped at the same stage.
As a contrast, I removed 3 Na atoms in POSCAR (as uploaded as POSCAR(2)), and the Bader worked perfectly even at 5x5x3 kpoints. It really confused me. I don't know what goes wrong with POSCAR1. btw I have tried to remove 1 Na atom from POSCAR1 (as uploaded as POSCAR3), script would still stopped at the same stage.
I wish to find out how can I calculate the Bader charge of POSCAR1, which parameters shall I adjust.

I appreciate if you can help me with these questions. Many thanks

Best,
Timmons
Attachments
POSCAR1.txt
(7.38 KiB) Downloaded 84 times
POSCAR (2).txt
(7.14 KiB) Downloaded 87 times
INCAR.txt
(543 Bytes) Downloaded 85 times
POTCAR.txt
(791.19 KiB) Downloaded 77 times
POSCAR3.txt
(7.26 KiB) Downloaded 84 times

graeme
Site Admin
Posts: 1910
Joined: Tue Apr 26, 2005 4:25 am
Location: University of Texas at Austin
Contact:

Re: Bader script is not responding while calculating Bader charge

Post by graeme »

If you can make the charge density files available to me, I'll run tests.

TimmonsWang
Posts: 3
Joined: Fri Nov 22, 2019 5:12 pm

Re: Bader script is not responding while calculating Bader charge

Post by TimmonsWang »

Dear graeme,
Thanks for your timely response. I have attached the CHG files for 1x1x1 kpoints case of POSCAR1. You may try to test if it runs well. If other files are needed, please contact me.
Attachments
AECCAR0.txt
(51.83 MiB) Downloaded 86 times
AECCAR2.txt
(51.83 MiB) Downloaded 83 times
CHGCAR_sum.txt
(54.68 MiB) Downloaded 88 times
CHGCAR.txt
(103.75 MiB) Downloaded 89 times

graeme
Site Admin
Posts: 1910
Joined: Tue Apr 26, 2005 4:25 am
Location: University of Texas at Austin
Contact:

Re: Bader script is not responding while calculating Bader charge

Post by graeme »

If you look in your AECCAR0 file, you will see that it is full of NaN (not a number) values. Vasp needs to output a proper AECCAR0 for the Bader analysis to work. I've seen this before but I'm not sure what causes it.

TimmonsWang
Posts: 3
Joined: Fri Nov 22, 2019 5:12 pm

Re: Bader script is not responding while calculating Bader charge

Post by TimmonsWang »

So this could be some bugs of VASP? Or i guess it is a problem generated from non ground state input structure. Many thanks for your kind response.

graeme
Site Admin
Posts: 1910
Joined: Tue Apr 26, 2005 4:25 am
Location: University of Texas at Austin
Contact:

Re: Bader script is not responding while calculating Bader charge

Post by graeme »

It is a problem with vasp, but again, I don't know what causes it. It would be nice if the vasp developers would look into it.

Post Reply